Currency Conversion Issue - Business Metrics
Incident Report for Game Analytics
Resolved
This incident has been resolved.
Posted May 15, 2019 - 17:22 UTC
Identified
We have found an issue with Revenue Metrics, where all monetary values are currently being shown in USD (even if the currency symbol is of a different currency). We are working on a fix that will be deployed as soon as possible.
Posted May 10, 2019 - 16:16 UTC
This incident affected: User Interface.